L2VSN Multicast over SPBM on VSP 7200

Task

Configure the L2VSN Multicast over SPBM on VSP 7200 and ERS 4800 in same network with IPTV Sender and IPTV Receivers.


Scenario

There is one network with IPTV Sender and IPTV Receivers. The Avaya ERS 8600 is a Core Switch and works as BCB in SPBM. The Avaya VSP 7200 switches work in Distribution Layer as BCB with NNI ports in SPBM and as SMLT Cluster with UNI ports in Legacy Network. The VSP 7200s need to receive the multicast signal from IPTV Sender network and send it to joined Multicast Clients (IPTV Receivers) over SPBM and Legacy Network. SPBM is already configured on all switches and it’s functional. For IPTV will be used the new VRF named “IPTV”. It will be configured only on Avaya VSP 7200, because the Core Switch use it already. Additional I will configure the IGMPv2 on all switches. Without IGMPv2 I can see only number of joins from IPTV Receivers but no IPTV Sender in IGMP sender table. With IGMPv3 I’m able to see the multicast traffic only on dedicated IPTV Receivers (TV Boxes) and not in applications such VLC. With IGMPv2 I’m able to receive the multicast traffic in VLC, too. Default test multicast address on IPTV Sender is 224.0.4.104 with UDP port 10004.


 Hardware | Software

  • Core Layer: Avaya ERS 8606 + BOSS v.7.2.11.0 (x2)
  • Distribution Layer: Avaya VSP 7254XSQ + VOSS v5.1.1.1 (x2)
  • Access Layer: Avaya ERS 3549GTS-PWR-PLUS + BOSS v.5.3.1.003 (x1)
  • Access Layer: Avaya ERS 4826GTS-PWR-PLUS + BOSS v.5.9.3.023 (x3)

Solution | Overview

Step 1: Prepare Avaya VSP 7200 switches ( BEB/BCB) in SPBM.

Step 2: Prepare both ERSes 4800 (BEB) in SPBM.

Step 3: Prepare ERS 3500 as Access Switch in legacy network.

Step 4: Verify the Multicast traffic on VSP 7200.

Step 5: Verify the Multicast traffic on ERS 4800 / ERS 3500.

Step 6: Make a final test on IPTV Receiver / VLC.


Solution | Detailed

Step 1: Prepare Avaya VSP 7200 switches (BEB/BCB) in SPBM.

Create VRF named “IPTV” and new VLAN with SVI interface for this network. On 2nd Distribution Switch use next free IP address. Add the VLAN to Uplink Port (Gigabit Ethernet 1/23) in Legancy Network for traditional Access Switch.

ip vrf iptv vrfid 2

vlan create 904 name "IPTV-TEST" type port-mstprstp 0
vlan members add 904 1/23 portmember
vlan port 1/23 tagging tagAll

interface Vlan 904
 vrf iptv
 ip address 172.21.62.5 255.255.255.0
exit
  • ip vrf Creates VRF instance with instance ID.
  • vlan create – Creates VLAN with specific type (port, protocol, or SPBM).
  • vlan members add Adds ports to VLAN. 
  • vlan port – Modifies VLAN port settings.
  • interface vlan  – Enter interface configuration mode for VLAN.
  • vrf Associates a port to a VRF, so that the port becomes a member of the VRF instance.
  • ip address – Configures the IP address for the port.

*

Activate Multicast over SPBM and associate new I-SID with created VLAN.

router isis
 spbm 1 multicast enable
exit

vlan i-sid 904 200904
  • router isis – Enter IS-IS router configuration mode.
  • spbm multicast enableEnables SPBM multicast globally. Default is disabled.
  • vlan i-sid – Associate C-VLAN with I-SID.

*

Configure IGMPv2 on SVI interface.

interface Vlan 904
 ip igmp query-interval 60
 ip igmp proxy
 ip igmp router-alert
 ip igmp snooping
 ip igmp snoop-querier
 ip igmp compatibility-mode
 ip igmp immediate-leave
 ip igmp mrdisc
exit
  • ip igmp query-interval – Sets the frequency at which host query packets are transmitted on the VLAN. Default is 125 sec.
  • ip igmp proxy – Enables IGMP proxy on a VLAN. Default is disabled.
  • ip igmp router-alert – Enables the router alert feature. Router drops control packets that don’t have the router-alert flag in the IP header.
  • ip igmp snooping – Enables IGMP snooping for a VLAN.
  • ip igmp snoop-querier – Enables IGMP querier.
  • ip igmp compatibility-mode – Activates v2-v3 compatibility mode. Default is disabled.
  • ip igmp immediate-leave – Enables fast leave members.
  • ip igmp mrdisc – Activates multicast router discovery and its parameters.

———

Step 2: Prepare both ERSes 4800 (BEB) in SPBM.

Activate the SPBM loopback port with changing the reserved-port to “front-panel” or “stack”. Setting the rear-port to “front-panel” will make switch’s last interface inaccessible, recommended for stack switch. Setting the rear-port to “stack” will make switch’s rear stacking port inaccessible, recommended for stand-alone switch. Choose your parameter and reboot the device. Switch will be rebooted with partial-default config, so make sure to do an ACII backup. Recovery from BIN backup file will not work.

spbm reserved-port stack
! or
spbm reserved-port front-panel

*

Activate the multicast over SPBM. Create new VLAN and prepare an Access Port (Fast Ethernet 1) for IPTV Sender / IPTV Receiver. Then create the new I-SID for this VLAN.

router isis
 spbm 1 multicast enable
exit

vlan create 904 name "IPTV-TEST" type port
vlan members add 904 1
vlan port 1 pvid 904
vlan port 1 taggind disable
vlan port 1 filter-unregistered-frames disable
vlan port 1 filter-untagged frames disable

vlan i-sid 904 200904

*

Configure IGMPv2 on SVI interface.

interface vlan 904
 ip igmp router-alert
 ip igmp snooping
 ip igmp send-query
 ip igmp query-interval 60
 ip igmp version 2
exit

———

Step 3: Prepare ERS 3500 as Access Switch in Legacy Network.

Create the VLAN, a Tagged Uplink Port (Fast Ethernet 1) as connection with BEB and an Untagged Access Port (Fast Ethernet 5) for a IPTV Receiver.

vlan create 904 name "IPTV-TEST" type port

vlan members add 904 1
vlan port 1 taggind enable
vlan port 1 filter-unregistered-frames enable
vlan port 1 filter-untagged frames enable

vlan members add 904 5
vlan port 5 pvid 904
vlan port 5 taggind disable
vlan port 5 filter-unregistered-frames disable
vlan port 5 filter-untagged frames disable

*

Configure the IGMPv2. You can use the mrouter setting to define the link, on which the multicast router is available.

interface vlan 904
 ip igmp router-alert
 ip igmp snooping
 ip igmp send-query
 ip igmp query-interval 60
 ip igmp mrouter 1
exit
  • ip igmp mrouterAdds one or more static mrouter ports to a VLAN.

———

Step 4: Verify the Multicast traffic on VSP 7200.

First, check the SVI for VLAN 904.

show ip interface vrf iptv
**************************

==========================================================================
IP Interface - VRF iptv
==========================================================================

INTERFACE  IP           NET            BCASTADDR  REASM    VLAN  BROUTER
           ADDRESS      MASK           FORMAT     MAXSIZE  ID    PORT
--------------------------------------------------------------------------
Vlan904    172.21.62.5  255.255.255.0  ones       1500     904   false

*

Check the IGMP interfaces. The IGMP querier is the VSP 7200 switch itself.

show ip igmp interface vrf iptv
*******************************
 
============================================================================================
Igmp Interface - VRF iptv
============================================================================================

QUERY                      OPER               QUERY   WRONG              LASTMEM
IF     INTVL STATUS  VERS. VERS  QUERIER      MAXRSPT QUERY JOINS ROBUST QUERY    MODE
--------------------------------------------------------------------------------------------
V904   60    active  2     2     172.21.62.5  100      0    188   2      10       snoop-spb

1 out of 1 entries displayed

*

Check the IGMP cache. The 224.0.4.104 is the test multicast address on IPTV Sender. 172.21.62.101 is one of the IPTV Receivers.

show ip igmp cache vrf iptv
***************************
 
================================================================================================
IGMP Cache - VRF iptv
================================================================================================

GRPADDR      INTERFACE  LASTREPORTER   EXPIRATION             V1HOSTTIMER  TYPE     STATICPORTS
------------------------------------------------------------------------------------------------
224.0.4.104  Vlan904    172.21.62.101  0 day(s), 00h:01m:17s  0            DYNAMIC  NULL
227.5.6.77   Vlan904    172.21.62.101  0 day(s), 00h:01m:15s  0            DYNAMIC  NULL

*

Check the IGMP group. You can see the port to IPTV Receiver,

show ip igmp group vrf iptv
***************************
 
============================================================
Igmp Group - VRF iptv
============================================================

GRPADDR      INPORT      MEMBER         EXPIRATION  TYPE
------------------------------------------------------------
224.0.4.104  V904-1/23   172.21.62.101  113         Dynamic
227.5.6.77   V904-1/23   172.21.62.101  115         Dynamic

2 out of 2 group Receivers displayed

Total number of unique groups 2

*

Check the IGMP sender. There should be the IP from IPTV Sender, 172.21.62.11.

show ip igmp sender vrf iptv
****************************
 
==========================================================
Igmp Sender - VRF iptv
==========================================================

PORT/
GRPADDR      IFINDEX   MEMBER        MLT    STATE
----------------------------------------------------------
224.0.4.104  Vlan 904  172.21.62.11  spb    NOTFILTERED

1 out of 1 entries displayed

*

You can check almost all these important information with other command.

show ip igmp snoop-trace vrf iptv
*********************************
 
=============================================================
Snoop Trace - VRF iptv
=============================================================

GROUP        SOURCE        IN    IN    OUT   OUT   TYPE
ADDRESS      ADDRESS       VLAN  PORT  VLAN  PORT
-------------------------------------------------------------
224.0.4.104  172.21.62.11  904   spb   904   1/23  NETWORK

*

Of course don’t forget about IS-IS LSDB with TLV 185 (IPVPN Multicast). Our BEB with IPTV Sender is named SPBM-SENDER.

show isis lsdb tlv 185 detail
*****************************
 
====================================================================================================
ISIS LSDB (DETAIL)
====================================================================================================

Level-1 LspID: 0001.0001.9991.00-02 SeqNum: 0x00000004 Lifetime: 1122
 Chksum: 0xfd88 PDU Length: 87
 Host_name: SPBM-SENDER
 Attributes: IS-Type 1, Overload

TLV:185 SPBM IPVPN :
 VSN ISID:200904
 BVID :4051
 Metric:0
 IP Source Address: 172.21.62.11
 Group Address : 224.0.4.104
 Data ISID : 16000003
 TX : 1

 VSN ISID:200904
 BVID :4052
 Metric:0
 IP Source Address: 172.21.62.11
 Group Address : 224.2.127.254
 Data ISID : 16000004
 TX : 1

———

Step 5: Verify the Multicast traffic on ERS 4800 / ERS 3500.

On BEB use these commands.

show isis lsdb tlv 185 detail
show ip igmp snooping
show ip igmp interface
show ip igmp cache
show ip igmp group

*

On Access Switch use these commands.

show ip igmp snooping
show ip igmp interface
show ip igmp cache
show ip igmp group

———

Step 6: Make a final test on IPTV Receiver / VLC.

Just start the box and verify the TV signal. Optional you can use VLC with link rtp://@address:port (Example rtp://@224.0.4.104:10004).